1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

LED fades on tc electronic booster linedriver & distortion

Discussion in 'Effects [BG]' started by appan, Feb 26, 2008.


  1. appan

    appan

    Jan 29, 2008
    Hi!

    Have anyone experienced that the LED on the old tc booster fades half a minute after kicking it in? This happens to me, both when using batteries and wall-wart. I don´t know if it is supposed to do that and the tc support page or manual don´t give any clues.

    kind regards
    Per
     
  2. jasper bos

    jasper bos

    Oct 10, 2005
    Endorsing artist: mesa/boogie
    Hi, i also happen to own one of these old pedals, and the LED is supposed to fade after 30 seconds, in order to save energy. Mine does this as well, which can be pretty annoying. However, since I only use it for distortion, I have a fairly good idea when the thing is on or not.

    Cheers,

    J
     
  3. appan

    appan

    Jan 29, 2008
    H and many thanks for your answer. I am pretty shure it stayed on without fading when I used it with an original tc SC protected power supply, but that piece is gone... Have you tried it with one of those supplies?

    /Per
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.