Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Low volume in an EMG

Discussion in 'Pickups & Electronics [BG]' started by Gianni, Jun 7, 2005.


  1. Gianni

    Gianni

    Jul 4, 2001
    Palermo - Italia
    Hello! :hyper:

    I have an old steinberger L2 or XL2 with active EMG soapbars and electronics with 2 volumes and a passive tone control.

    The neck PU has a lower volume than the bridge one, the tone frome the neck PU seems ok, but the volume is lower..

    I am sure, because I touched both PUP's with a screwdriver and the noise produced by the Neck PU was lower.

    There is a problem with the internal preamp of the PU or it could it be a problem in the potentiometer?

    What do you think about?

    Ciao!
    Gianni
     
  2. eldave777

    eldave777

    May 24, 2005
    If the pickups have seperate volume pots I would try new pots. You will need 25k pots for EMG's.
     
  3. luknfur

    luknfur

    Jan 14, 2004
    DIXIE
    FWIW:

    all else being equal, if the neck pup is weaker than the bridge, there is definitely something amiss. You could either check the volume pots with a meter or simply switch them with the pups. If the neck becomes much louder than the bridge (which it normally is), then the weaker pot probably needs replaced.

    Could be the issue is caused by something else but the volume pots would be an obvious probable source.
     
  4. Gianni

    Gianni

    Jul 4, 2001
    Palermo - Italia
    Thank you for your answers eldave777 and luknfur!

    I will try to exchange the pots...

    Ciao!!
    Gianni
     
  5. alibloke

    alibloke

    Dec 17, 2004
    Bristol, England
    Just a quick thought. Do your EMGs have the KWIK connect sockets on them? If so, are the arrows on the plug lined up with the ones on the pickup?