1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Markbass LMIII Repair help

Discussion in 'Amps and Cabs [BG]' started by Jasisco, Jan 25, 2012.


  1. Jasisco

    Jasisco

    Mar 30, 2010
    I recently ran some pedals through the effects loop on the back of this amp to try out. Silly of me one of my patch leads was cheap and of poor quality and when I removed it the tip of the jack had come off. It is still lodged in the 'return effect' input and near impossible to remove without opening up the amp which is something I'm trying to avoid.

    I don't intend to use the effects loop but I'm wondering if this will in some way affect the sound. It's hard to say a I don't notice a difference most of the time but sometimes I do. An almost out of phase like tone. Now, this could very well be my ears and brain playing tricks on me because I know that the tip of the jack is still stuck in there.

    Can anyone tell me if it is possible this could at all affect the amps performance?
     

    Attached Files:

  2. Jasisco

    Jasisco

    Mar 30, 2010
    bump
     
  3. Russell L

    Russell L

    Mar 5, 2011
    Cayce, SC
    Can't you just take the top off? There are screws, and I don't think it will interfere with anything. Then you might could push the plug tip out?

    I don't know if it hurts anything for it to be in there. Someone else will have to answer that. But, I'd be taking the top off, if it were me, just to see if I could reach the plug. The worst that could happen is that you just put the top back on.
     

Share This Page