Mesa/Boogie M2000 Schematics

Discussion in 'Amps and Cabs [BG]' started by icks, May 6, 2005.

  1. icks


    Jul 12, 2001
    Charleroi, Belgium

    I had some weird clipping style problem last gig with my amp, I'm gonna bring it to a tech for a first 'in a decade' annual check. He told me never work on a M2000 so I'd like to have the schematics on this amp.

    Anyone has them ?

    Thanks a lot

  2. Transverz

    Transverz believer of the Low End Theory

    May 3, 2004
    Los Angeles, CA
    Hey fellow M-2000 user! Sorry about the problems. I don't have the schematic, but shouldn't Mesa Boogie be able to send you one right away? I mean, even if they charge you a couple bucks for it (God forbid) at least it'll be better than going to the tech without one and him doing something crazy with your amp.

    Hmm. Wonder what it could be. Have you checked the tubes and make sure they are all firing? Seems like the easiest thing check out while you are waiting for the schematic. Might even save on the bench fees and time. Have you hooked it up again after the gig to cabs you know work properly? Sometimes I also have weird sort of problems at gigs and realize it was my haste or the soundguy that made it sound like something was wrong.

    Anyway, hope all is good or not too bad with the amp. Best of luck!

  3. icks


    Jul 12, 2001
    Charleroi, Belgium
    i was playing on the tube channel when it happened so I changed to the Fet channel and it happened again. I'll try to send a email to mesa.

    I wasn't using the PA system, because I had a hum noise using my balanced output, usualy I use it to the mix with no problem.