1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

MIDI Help: Alesis SR-18 and Eventide Timefactor

Discussion in 'Effects [BG]' started by BooshBass, Sep 27, 2013.


  1. BooshBass

    BooshBass

    Sep 2, 2013
    Chicago, IL
    Hey all,

    I recently got an Alesis SR-18 and an Eventide Timefactor and am having trouble syncing their tempos with MIDI. I plan to use an RC-300 as the master when it arrives next week and anticipate having the same problem.

    Right now when I set the Timefactor to clock recieve on and the drum machine to clock send they don't sync. Same thing when the drum machine is set to receive the clock and the Timefactor is set to send.

    I've never used MIDI before so it could just be me not knowing some other settings I need to put on. Any ideas on what it might be?

    Also I am currently using a dual MIDI cable where one side is gray and one side is red. I just hook only the grey up to each device. Could this be the problem? Are dual midi cables different from single ones?

    Another thing, when I switch the Timefactor to MIDI clock receive on, it blinks. None of the other midi parameters blink when I change them. Is this trying to tell me something?

    I looked through the user manual to no avail. Any suggestions/help are welcome. Thanks in advance.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.