Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

my amp wont make any noise

Discussion in 'Amps and Cabs [BG]' started by Avril, Jan 6, 2003.


  1. Avril

    Avril

    Aug 23, 2002
    like i said, my crappy crate gx-15 wont make any noise when i plug it into my bass. im pretty sure its not my cord becuase i just bought it and it works fine on other amps. does anyone know how to fix this?
     
  2. rickbass

    rickbass Supporting Member

    The word that immediately comes to my mind is "warranty."

    Specifically, the Crate 5 yr (electronics)/2 yr. (speaker) warranty.
     
  3. Steven Green

    Steven Green

    Jul 25, 2001
    Pacific NW
    less noise = better;)
     
  4. PICK

    PICK

    Jan 27, 2002
    Sydney, Australia
    Theres your problem!!! I always plug my bass into my amp, not my amp into my bass. :D :p
     
  5. try pluggin your amp in. it could also be the input jack on your amp.

    Then again, why would your crate not work? Crates blow ass but they are as sturdy as fender basses are...
     
  6. Replace the Fuse.
     
  7. 1) Does the power light come one?
    2) If it does, can you hear any sound (hiss) coming from the speaker?
    3) If there is any sound at all coming from the speaker, what does it sound like?

    When you make a statement like "my crappy crate amp won't make any noise" it is hard to come up with any solution without some useful information....:p