Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

My Ashdown EVO500 II is dead.. HELP !

Discussion in 'Amps and Cabs [BG]' started by Kelu, Aug 29, 2005.


  1. Kelu

    Kelu

    Dec 6, 2002
    Lille in France
    I made a tour in France this summer, I told the drummer to take back home my amp.. I went take him this morning and.. it's dead.
    I spot 3 problems :
    - The electricity works but the two cooling fans dont work.
    - The sound it get from it is very noisy (as if the speaker was dead but the speaker if working, I test it with another amp..) and is really more quieter than before.
    - On the back, the bar which maintient the female jack inputs is fall in the amp.. very nice..
    I cant believe all these things happened just by driving.. Even if the head wasnt lie on this rubber foot.
    The drummer told me that nothing happened with the head, but I'm sure it hurt the floor..
    What do you think ??
    I send it to Ashdown factory today, do you think repairs will be expensive (I do..) ?
    Has anyone had troubles before with EVO500 ??
    It isnt garanteed anymore.. :bawl:
     
  2. JayAmel

    JayAmel Moderator Staff Member Supporting Member

    Mar 3, 2002
    Aurillac, France
    Aren't Ashdown amps covered by a 5-year warranty ?
    If so, I think your ABM500 EVO II is still under warranty, since the EVO II series is far less than 5 years old...
     
  3. Kelu

    Kelu

    Dec 6, 2002
    Lille in France
    I thought it was one year only..
    nyway, the type of damage on the head wont works with the warranty..
     
  4. thats a bummer. from friend's experiences theyve all had good luck with the ABMs so don't fret. Ashdown are a great company imo - specially with Trace techs working with them ;)