Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

My Classic 400 Tubes - I Think Mine Are Different

Discussion in 'Amps and Cabs [BG]' started by Quadzilla, Nov 23, 2005.


  1. Quadzilla

    Quadzilla Supporting Member

    All-

    I just got my new Classic 400 and before firing it up, I went into the head to make sure that all of the tubes were socketed properly.

    As for the power tubes, they appear to be the KT88's with the straight sides. Here is where I think it gets weird. My pre-amp tubes are as follows (looking from the front):

    My front 3 are Electro Harmonics 12AX7EH's
    The rear 3 are (starting from the left) 2 - Sovtek 12AX7LPS's and then the last one on the right is a JAN Phillips ECG 12AT7WC AGX.

    Is this tube setup from the factory unusual? I don't recall others having this setup from the Peavey factory (I could be wrong). I thought that most if not all said that theirs came with all Chinese pre-amp tubes.

    My Classic is one with the non-pointed Peavey (newer) logo on the front and it had a hang tag on it that read:

    "Classic 2001 World Tour"
    "Access All Areas"

    In any event, the head fired up and works like a champ! I only have about 10 minutes on it.
     
  2. bigbeefdog

    bigbeefdog Who let the dogs in?

    Jul 7, 2003
    Mandeville, LA
    I didn't take a complete inventory, but my front 3 were E-H as well.

    And the rest of your description sounds exactly like mine - "block" logo, hang tag, etc.

    Mine was also packaged with a warranty paper that said 2 years, plus an additional 3 years if the card is returned promptly, on "amplifiers", among other gear. Wonder if THAT applies?
     
  3. Quadzilla

    Quadzilla Supporting Member

    Well it appears that ours may have been made later than '99 being that they have the newer logo and have a 2001 promotional hang tag on them (plus the different pre-amp tubes to boot).
     
  4. Mine also had at least one Elec. Harm. in it, didn't check the others. Had the 2001 classic tag and pointed peavey logo on the amp (not straight).
    They may have been planning to sell them in 01 who knows.
     
  5. SubMonkey

    SubMonkey

    May 3, 2004
    Denver, CO
    Fun stuff... Mine is a "block logo" model as well... but came loaded with chi-com pre-amp and power tubes... I hadn't really considered this before, anyone know when peavey changed to the 'non lightning-bolt logo' ?

    dang this place is slowly developing a Classic 400 owners group....

    SM
     
  6. That's exactly mine, same tube complement, hang tag, logo, etc.

    Does everybody else's power tubes rattle like mine??
     
  7. timv

    timv Supporting Member

    Jun 7, 2000
    Chandler, AZ
    Thats what my tube compliment is also, block logo, 2001 hang tag...
     
  8. James Hart

    James Hart

    Feb 1, 2002
    toms_river.nj.us
    Endorsing Artist: see profile
    in the works! I'll be having a registry and the ability to set up individual pages with links to players bands and stuff!

    I'm open to suggestions as well.... I'm hoping to be up and running mid Jan

    oh and I bought mine tubeless and used. Mine came with the lightning bolt logo but I swapped it for an open grill and the block logo off my old Microbass 3