Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

My F-1X

Discussion in 'Amps and Cabs [BG]' started by Pre EB, Dec 5, 2002.


  1. Pre EB

    Pre EB

    Mar 15, 2002
    Denton, Tx
    After replacing three tubes in the past month, my dang old pre is STILL messing up! ChuckM sent me a new tube and that went weird after playing it for approx. 30 minutes.
    Here's what happened the last time:
    I replaced the tube.
    I played for thirty minutes and it sounded great.
    I turned it off.
    I turned it on the next day to practice.
    I got a whooshing ocean-like sound and very little volume.
    I have not turned it on since. Please help! Anyone know a GOOD tech in the DFW area?
    Thanks, Joe
     
  2. Yes yes yes!!
    ...and not that far from Denton either. Its Jim at Texas Guitar and sound: Business 121@corporate (behind the McD's). Jim knows everything about everything (im fairly knowledgeable and he amazes me everytime). Incidentally, it wasnt long ago that He and I spoke at lenght about the Alembic F1x to add to my arsenal.

    It may or may not help, but tell him Corey sent you (i've used him for years and referred alot of folks, none dissatisfied).

    His prices are reasonable as well.
     
  3. Pre EB

    Pre EB

    Mar 15, 2002
    Denton, Tx
    Thanks Cory,
    I've known Jim since he worked at McBrides here in Little D! I forgot he did amp work but I've been in his shop several times in the last few months. Nice guy and has been very trustworthy.
    BTW, how long have you been in the area? I'd bet we know some of the same players if you've been in the scene since the early to mid 90s.
     
  4. been in DFW for 15 yrs. I've played in some regionally known bands (and some real clunkers, too :)) : Pen15, Smart Aleck, jay Quinn Band, Jason Carrell, and currently in Wee Hour Movie (www.weehourmovie.com). Undoubtedly, we know wome of the same folks.

    We still need to hook up, i really want to hear an Acme in real life. I work in Lewisville, perhaps one day...
     
  5. Pre EB

    Pre EB

    Mar 15, 2002
    Denton, Tx
    You weren't the Cory in The Mussels or Whitey, were you? Gotta love those Deep Smellum Dumps!
    I guess not or you would've mentioned Denton in your resume.:)
    E-mail me and we can get together and jam soon. After the Holidays (I'm very busy at this time) I'll have lots of time.
     
  6. nope, not me.

    Ill get in touch after the madness.
     
  7. Hey Pre I'll take a stab at this one.
    I never had and FX1 but from what I've read over and over that pre is very "Fender" like in construction likewise the front end of my Mesa Boogie 400+. I had the same problem with some 12ax7 I installed. I would start it up and play and as soon as I turned is off and back on I would get the same "swishing sound" and that is it, no bass. I replace the Sovted LPS about four times and gave up. I put the Mesa tubes back in until I found the 12ax7EH I use now. I'm not sure if there was somehting wrong with the earlier LPS tubes or my Fender Like preamp section of my Boogie just did not like the tube/voltage etc. Hope this might help a little.
     
  8. Pre EB

    Pre EB

    Mar 15, 2002
    Denton, Tx
    Thanks,
    I really do hope that is the probem.