Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

My P/bass is humming like crazy

Discussion in 'Pickups & Electronics [BG]' started by Jazzbassman23, Jul 16, 2001.


  1. Jazzbassman23

    Jazzbassman23

    Apr 20, 2000
    Maryland
    I can never leave well enough alone, so I removed the pickguard on my P/bass to have a look, and when I replaced it and plugged in, it's humming like crazy. Before it only had the normal amount of P/bass hum, but now . . . When I touch the strings, it goes away. While I had it open, and after it started humming, I shielded the cavity w/shielding paint, but that made no difference. I don't seem to have loosened any wires. Any ideas?
     
  2. brianrost

    brianrost Gold Supporting Member

    Apr 26, 2000
    Boston, Taxachusetts
    Obviously you removed a ground from something important. I'd go over all the wiring very carefully.

    If the hum goes away when you touch the strings, then the ground wire to the bridge is intact, anyway.
     
  3. Jazzbassman23

    Jazzbassman23

    Apr 20, 2000
    Maryland
    Thanks, Brian, I'll give that a look tonight.

    Dave
     
  4. Jazzbassman23

    Jazzbassman23

    Apr 20, 2000
    Maryland
    Brian, Thanks for the help. I should clarify in that I was working on a 77 Ibanez P/Bass copy whose wiring is slightly different than that shown on Fender's wiring diagram. Anyway, everything looked intact, so I ran a wire from one of the jack leads to the cavity which has been sheilded with paint. I should have screwed it down, but for now I just affixed it with sheilding tape. As I was putting the pickguard screws back in, I knew I should have screwed it down, but . . . NOW, this baby is dead quiet. Thanks, man.

    Dave