1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

My pedal turns on but doesn´t send any effect...

Discussion in 'Effects [BG]' started by IguanaFish, Nov 28, 2018.


  1. Hey!
    I´m having this problem with my pedal, I have a DOD Bass Stereo Chorus fx62, it was working great, i was playing with my effects chain but suddenly it just stopped sending any "chorus" signal, but it still turns on and makes that "clicking" noise when it is engaged or disengaged ¿What can it be? None of my other pedals stopped working just that one)
     
  2. ErnieD

    ErnieD

    Nov 25, 2004
    Atascocita,TX.
    Maybe just a bad or loose patch cable? Check all connections or remove that pedal from your board. Try different patch cable(s) on it, power source, other cables, etc. Hope it's something simple to fix.

    Y tambien, make it sure cables are connected in the correct input/output. I move pedals on/off my mini pedal board and sometimes run the inputs wrong, DOH! :banghead: Buena suerte hermano.
     
    IguanaFish likes this.
  3. I´ve already checked that, it isn´t any of those options :C But thank you! Lets see it there´s any luck in the replies of the post hahaha
     
  4. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    Mar 2, 2021

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.