Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Need Help!! Bartolini Preamp Woes..

Discussion in 'Pickups & Electronics [BG]' started by piper2614, Jan 16, 2006.


  1. piper2614

    piper2614

    Nov 17, 2004
    Happy Bottom
    hey now,

    ill first mention that i am very ignorant to alot of things, please excuse me in advanced.. i recentely purchased and installed a bartolini 5.3 preamp into my schecter 5 string bass.. the bass originally had a 2 band emg pramp and emg hz pickups. i chose to stick with the emg hz pickups.. .. so ive soldered the pickups(green wire) to their proper knobs.. soldered the ground wire properly to the "ground tab on the pots..i didnt solder the braided shielding that surrounded the wires..(this was originally soldered from schecter to the top of the pots)i soldered the power wires together..i havnt soldered the bridge and or grounded anything else.. now lies my problem.. when i plug the bass in and the preamp a/p switch is pushed in , ive got absolutely no to very little output...(im assuming this is passive mode.?? ) so i pulled the knob out and get this really loud POP...plenty of volume .. however the volume knobs are insanely noisy?? i can here it in the amp when i turn them ( a hissing sound is how i would describe it) also get the nice buzz until i touch the knobs..?? any ideas.?? do i need to solder the braided shielding? ill gladly post pic's if needed. thanks in advanced to all..

    michael
     
  2. piper2614

    piper2614

    Nov 17, 2004
    Happy Bottom
    ive fiddled with a little bit more and found another thing to mention. when the bass knob is at center and the volume knob pulled out there is no volume. when i turn the knob slightly i get a major high pitched squeal ??

    ive been all over the net and to emg and bartolini's respective sites. the wiring diagrams are useless at best.

    very confusing..

    thanks
     
  3. David Wilson

    David Wilson Administrator Staff Member Administrator Supporting Member

    Oct 14, 2002
    Lower Westchester, NY
    can you take photos of how you've wired it? Is this your first time doing such a job?

    Although you've soldered ground wires to back of pots, do you have a path to ground? If the pots themselves don't have a path to ground, that doesn't help.
     
  4. piper2614

    piper2614

    Nov 17, 2004
    Happy Bottom
    hey david,

    yes this is my first time doing this. :rollno: my concern going in was the amount of wires the pickups had. the hz has 1 bare wire (i assume is ground) 1 red, 1 green, 1 white, and 1 black.. schecter had the white and black wires soldered together and heat shrinked. i dont know proper termonolgy but i soldered the green wires to the center "lug" of the respective pots. the bare ground i soldered to the ground "lug" on the respective pots that bartolini had already grounded . ( bought the pre , prewired) so all ive pretty much done was soldered the 2 wires to the pots. i havnt soldered anything to the back of the pots.

    ill post photos this afternoon..

    thanks again for your time
     
  5. piper2614

    piper2614

    Nov 17, 2004
    Happy Bottom
    here are the pics. sorry for the poor quality. the green wire in the center of each pic i wired along with the ground to the left. all the red wires are soldered together and attached to the battery.

    after reading a bit im not sure this pre can even be matched with these pickups. it seems emg is pretty specific to their own brand..

    any help is much appreciated.
     

    Attached Files: