1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

**** Need Help getting my Vintage ElectroniX Submarine pedal fixed****

Discussion in 'Effects [BG]' started by SirMjac28, Apr 2, 2013.


  1. SirMjac28

    SirMjac28 Patiently Waiting For The Next British Invasion Gold Supporting Member

    Aug 25, 2010
    The Great Midwest
    I finally got one of the pedals I have been lusting over and I'm having trouble with it. The pedal causes my amp's clip light to come on and stay on as long as the pedal is connected also the only sound from the pedal is a loud buzzing . I took the back plate off thinking maybe a wire was touching the metal back plate but I didn't see anything? and if I just connect the output cable and touch the input plug it still clips. I tried using a battery but the bypass light won't come on and it still clips like crazy. I cleaned all of the plugs with deoxit but I still have the same problem. I tried contacting Zeibek the company that makes the current Submarine and after three emails I give up with them if anyone knows how to contact the original designer of these pedals or someone who could fix it I would appreciate it.



    Here are a couple of pictures



    IMG_0076_zps74b885eb.


    IMG_0078_zps33caaa35.
     
  2. Without really knowing anything, it sounds like a bad stomp switch. No LED, and it doesn't pass sound in bypass, is that right? If that is the case I'd guess bad 3pdt.
     
  3. SirMjac28

    SirMjac28 Patiently Waiting For The Next British Invasion Gold Supporting Member

    Aug 25, 2010
    The Great Midwest
    Thanks yes there is no sound just loud buzzing and my clip light stays on as long as the pedal is connected.
     
  4. That is so sad. Good luck fixing.
     
  5. Unless you can find something more obvious I'm going with 3pdt. If the switch was good, the LED should work and it should pass sound when bypassed.
     
  6. brotondo

    brotondo Supporting Member

    Feb 7, 2012
    Kimball MI
    sorry MJ!, is there any loose wires anywhere? I know you can't see much under the board.
     
  7. SirMjac28

    SirMjac28 Patiently Waiting For The Next British Invasion Gold Supporting Member

    Aug 25, 2010
    The Great Midwest
    Hey what's up? I looked for loose wires I unmounted the plugs? I'm not sure if the original designer is still involved with pedals or not?
     
  8. SirMjac28

    SirMjac28 Patiently Waiting For The Next British Invasion Gold Supporting Member

    Aug 25, 2010
    The Great Midwest
    The weird thing is the LED works only with pedal power it won't work with a battery?
     
  9. Well that complicates things. It could be an issue with the power jack, but any further than this and I'm getting into complete guess territory. It's not a good place for me to be. I also have to go and coach some soccer so it'll be a while before I can help anyway.
     
  10. brotondo

    brotondo Supporting Member

    Feb 7, 2012
    Kimball MI
    the overall pedal circuit design looks simple enough,thankfully the guy didn't goop epoxy over everything for secrecy purposes(seen that before) I feel any established electronics guru with the proper equipment could easily figure it out, meaning the original designer not being necessary for a repair,
    Analogman for example?
     
  11. SirMjac28

    SirMjac28 Patiently Waiting For The Next British Invasion Gold Supporting Member

    Aug 25, 2010
    The Great Midwest
    Thanks everyone for the help I'm also going to contact analogman
     
  12. SirMjac28

    SirMjac28 Patiently Waiting For The Next British Invasion Gold Supporting Member

    Aug 25, 2010
    The Great Midwest
    My Schumann Electronics Lion pedal has that going on.
     
  13. SirMjac28

    SirMjac28 Patiently Waiting For The Next British Invasion Gold Supporting Member

    Aug 25, 2010
    The Great Midwest
    I want to thank Dan W for coming to my rescue thank you again sir you are the best.
     
  14. brotondo

    brotondo Supporting Member

    Feb 7, 2012
    Kimball MI
    keep us posted on Dan W's findings! I'm dying to know what happened!
     
  15. SirMjac28

    SirMjac28 Patiently Waiting For The Next British Invasion Gold Supporting Member

    Aug 25, 2010
    The Great Midwest
    I will sir he should have it Monday
     
  16. SirMjac28

    SirMjac28 Patiently Waiting For The Next British Invasion Gold Supporting Member

    Aug 25, 2010
    The Great Midwest
    I can't thank Dan W my brother from another mother enough not only can he etch like a mofo but he took time out of his busy schedule and took care of me he changed both input and output jacks also the power plug the pedal is whisper quiet and has a tone so fat I should give weight watchers a call :) love this pedal still can't believe I finally got one !!!
     
  17. SirMjac28

    SirMjac28 Patiently Waiting For The Next British Invasion Gold Supporting Member

    Aug 25, 2010
    The Great Midwest
    I also have to thank my man brotondo he remembered I wanted his pedal and he contacted me you are the man sir I promise to love and cherish this pedal always.
     

Share This Page