1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Need help with cab

Discussion in 'Amps and Cabs [BG]' started by Storm Shadow, Mar 10, 2013.


  1. Storm Shadow

    Storm Shadow

    May 26, 2012
    NC
    I have a Ampeg SVT-7 PRO that i am running out of a Ampeg PR410E and it keeps cutting out when i crank it up. I played the head out of a SVT classic and never had this problem. Not sure if its the head going into protect mode since the cab is 8ohm 600w. Also, i am looking at the Ampeg SVT 215E and can get it for a great deal can't really find the specs for it, but would this be a better option to run the head with?:confused:
     
  2. LowKayString

    LowKayString

    Nov 15, 2012
    There are a million threads about this and a million different ideas but the difference with my answer is I have a Svt 7 in my studio at this very moment that I got out of warranty a few months ago that has the same problem so I'll put in my two cents. I don't know how to wire an amp or stuff like that so please take that into consideration. The amp goes into (I'm guessing) protect mode. Your rocking out and all of a sudden no sound, ya turn around and your green power light turns off and comes back on correct? Play a few notes, happens again? This happens to me EVERY TIME I play it through anything less than my Ampeg 6x10. In my opinion I think it's the impedance of the bottom. It doesn't like 8 ohm or 4x10's or 2x12's. It never happens (so far and I'm hitting my wooden wall so hard right now my hand hurts) on the 6x10 (which I adore the sound of). You know what I'm gonna do though? First I'm calling LOUD and telling them they know what the problem is and to just tell me the exact thing I need to tell the repair man to fix. If the repair shop can't make it shut down they can't fix it. They'll leave it on for 4 days and say nothing is wrong. Well start blasting Rage bass licks guys and watch the Christmas lights flicker. If I can't get a definitive answer and repair I'm selling it so fast Jack Bruce's head will spin. I have a cheap Behrenger amp that although doesn't have the same sound is reliable what ever I plug it into, and that my friend is rule numero uno when it comes to being a professional bassist RELIABILITY. Don't put up with that and I would te
     
  3. LowKayString

    LowKayString

    Nov 15, 2012
    Be weary of class D amps from now on.. Let me know what happens amigo
     
  4. Storm Shadow

    Storm Shadow

    May 26, 2012
    NC
    Well I went from using a Ampeg PR410H 8ohm cab, to a Yorkville XC808 4ohm and i have not had a problem with it since. I am guessing that a 8ohm cab just can not handle the SVT-7 Pro. When i bought the amp I used it with a 4ohm SVT Classic 8x10 and it was amazing, now that I am using the Yorkville I remember why I got the head in the first place.
     

    Attached Files:


Share This Page