New SWR Son Of Bertha doesnt work

Discussion in 'Amps and Cabs [BG]' started by mkl13, Oct 26, 2005.

  1. I just picked up a new SWR Son of Bertha 1x15 to go with my Goliath Jr. Got it home and low and behold very little sound comes out. It doesnt appear to be associated with the input plug (i assume) because if I go from the power amp to the bertha to the goliath the goliath sounds great but the bertha is very quiet with little to no bass. The woofer does appear to be working somewhat becase with the tweeter off I do get some sound just not much. Any suggestions on what the problem is? I can return it but it is a bit of a pain send it back through the mail.

  2. Trevorus


    Oct 18, 2002
    Urbana, IL
    Where did you order it? It sounds like it could be a damaged driver, or a messed up crossover. Either way, it should probably be returned.
  3. First...How is it like when you play with only the bertha.
    If there is the problem then thats the cab... bring it back to the shop.

    If it is OK....
    Then it's how you connect the cables between the cabs. If the connection is serial then the impedance of each cab become most concern and you should not do unless it is designed for. If its is parralel it should not effect this much though different impenence. (either 4 or 8 ohms SWR is doing for the cabs except the combos like SWR SRH is 2 ohms only)
    Does you amp has more than one output for speakers. If yes, try to connect them from the amp.
    If it is Speakon sockets ... check your cable how it is weled since there are 3 different purpose for it.