1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

No distortion?!?!? HELP!!!!

Discussion in 'Amps and Cabs [BG]' started by Sound Guy Paul, Oct 20, 2001.


  1. Ok I have a ADA MB-1 Preamp. There are three distortion settings on the tube side. Clean Edgy and Dirty. They all sound the same for some reason. I have never replaced the tubes, (bought it a few months ago off of Ebay) and I was wondering if the tubes might be worn out or something. Anyone who knows anything about tubes help would be greatly appreciated. Thanks a lot guys.
     
  2. Ok this slipped through the cracks so i am bringing it back up. Anyone have any idea if I have a dead tube?
     
  3. If I bought a used preamp, I'd have the tube replaced before it was even plugged in.

    If you don't know the age or the condition of the preamp tube... replace it.

    I would usually replace it immediately because I prefer my own 5751 or NOS 12AX7A, rather then OEM tubes or someone else's preferance.
     
  4. Thats a good point. i have to admit I do not know where these tubes originated from, but one problem is I know nil about tubes. Anyone know any good sounding tubes that get good distortion. I am not a heavy metal player, my playing is more jazzy, but I do play a lot of songs that would sound good with a little bit of distortion edge to them. If anyone knows a site where I can buy tubes i would be very greatful. I do not want to spend 50 bucks a tube either so keep it cheap if possible.