Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

No sound from computer running linux

Discussion in 'Off Topic [BG]' started by Bardolph, Nov 16, 2005.


  1. Bardolph

    Bardolph

    Jul 28, 2002
    Grand Rapids, MI
    I have speakers plugged into the sound jack on my motherboard (no sound card) and I'm sure everything is turned on and set how it should be, but I get no sound. I'm running suse linux 9.1, which I have no experience with. My friend said it might be a driver issue but knows nothing past that. Any suggestions?
     
  2. I'm no pro but what I would do is, go to what ever the equivalent of the control panel is in Linux and make sure all the levels are up and no mutes are turned on.

    Next I would try to find the equivalent of the "device manager" and see if it will give you some type of driver information. The Windows device manager list all the hardware in your comp. and will let you know if something is not working. Linux should have something similar. My guess is that you will have to update your driver to one that is compatible with Linux. Try the motherboards manufactures web site and see if they have drives available for your O.S.

    Does everything else work okay? Printer?

    Is Suse 9.1 a user friendly OS? I don't know much about Linux other than it is what the pro's usually use.
     
  3. what kind of computer do you have?
     
  4. seanm

    seanm I'd kill for a Nobel Peace Prize! Supporting Member

    Feb 19, 2004
    Ottawa, Canada
    Do:

    lspci
    lsmod

    and post the results here. This will give us an idea of the hardware and if the driver is installed.

    Or as a real hack:

    cd /lib/modules/`uname -r`/kernel/drivers/sound
    for f in *; do modprobe $f; done

    Mind the back ticks around uname -r. This will give you a sh*t pile of errors but the real driver may stick :p
     
  5. Like chunk said, I would make sure that the output is not muted, and that the volume levels are set appropriately high. (these settings are found in "volume control".) Most sound not playing issues in Linux I've heard about involve having a soundcard and onboard, and Linux is outputting to the onboard instead of the sound card, but this isn't it here.

    I would also try going to "multimedia systems selector" (under System-Preferences in Gnome.) and try selecting different options and hitting the "test" button. It's probably on ESD by default. Try putting it on OSS.

    Also try "killall esd" in the console and see if you get sound after that.