Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Noise in Series on L-2000

Discussion in 'Basses [BG]' started by Rafterman, Oct 20, 2001.


  1. i've got a small problem...

    my L-2000 hums whenever it's in active and in series mode.

    Anyone experiencin the same problems?

    what can i do to get rid of it?...shielding?
     
  2. Nino Valenti

    Nino Valenti Commercial User

    Feb 2, 2001
    Staten Island NYC
    Builder: Valenti Basses
    I plugged in my L-2500 into my small Hertke B-20 & there was some hum. The closer I went to my amp/tv/telephone/alarm clock/etc the louder the hum got. I don't know why G&L don't just sheild the basses themselves. I have an 84 L-2000 (only works passive:() & there is sheilding paint on the inside of the cavity. Guess they're trying to cut costs down or are just plain cheap/lazy. :)
     
  3. where do you get the shielding paint?...Guitar Center?
     
  4. Nino Valenti

    Nino Valenti Commercial User

    Feb 2, 2001
    Staten Island NYC
    Builder: Valenti Basses
    It came stock from G&L in 1984 w/sheilding paint.
     
  5. Harpo

    Harpo

    Feb 1, 2001
    Kings Park NY
    My 99 L-2000 has no noise what so ever
    Nino when did you get the l-2500
     
  6. Nino Valenti

    Nino Valenti Commercial User

    Feb 2, 2001
    Staten Island NYC
    Builder: Valenti Basses
    About a month or 2 ago. Whan I played it the studio, I didn't notice any noise. I have to bring it back to the studio this Tuesday & give it another run.