1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

p bass deluxe pre amp problem

Discussion in 'Pickups & Electronics [BG]' started by jimmyjokerz, May 25, 2011.


  1. jimmyjokerz

    jimmyjokerz

    May 25, 2011
    hey guys

    i bought a p bass (fender) deluxe with a built in pre amp to make it active. all of a sudden there seems to be a problem with the electronics. when the pre amp is on sometimes the freequency is really low then all of a sudden it will go blasting....varying levels from my bass amp. i just wondered if anybody could give me some advice as what the problem is and what part i need to fix this problem, which must be to do with the electronics in the pre amp as it only happens when its switched on!! much appreciated
     
  2. Did you buy it new or used? If new take it back and have them either fix it or replace it.
     
  3. jimmyjokerz

    jimmyjokerz

    May 25, 2011
    i bought it new over 18 months ago so the warrenty is gone now!! i reckon i could fix it myself if i knew what part was playing up lol
     
  4. Im pretty sure Fender has a better warranty policy then 18 months. Just for kicks have you checked the battery? It could be dying.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.