Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

pickguard and pickups conflict

Discussion in 'Pickups & Electronics [BG]' started by lostinflyz, Feb 3, 2005.


  1. lostinflyz

    lostinflyz

    Feb 3, 2005
    ok im either outta the loop or something seriously screwwy is going on. i slapped a pair of bart p bass pickups into a project im working on. then i put on a gold anonized pickguard. but when you connect the pots to the pickguard it all dies. im sorry but what the hell is going on. helPPPPPP!!!!
    everything works prior to touching the pots to the stupid pickguard. any help would be just dandy
     
  2. xyllion

    xyllion Commercial User

    Jan 14, 2003
    San Jose, CA, USA
    Owner, Looperlative Audio Products
    You have an error in your wiring and as a result, you are creating a short when you connect the pots and jack to the conductive pickguard. This is not the fault of the pickups.
     
  3. lostinflyz

    lostinflyz

    Feb 3, 2005
    thanks. i sorta firgured that. you wouldn't happen to know or have an idea as to where this wiring slip up might be do you?? thanks again
     
  4. xyllion

    xyllion Commercial User

    Jan 14, 2003
    San Jose, CA, USA
    Owner, Looperlative Audio Products
    Follow where the hot goes. At no point should it be connected to the pot casings or the sleeve of the input jack. On the other hand, verify that the grounds are connected to the pot casings and the sleeve of the input jack.