1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Please Help!...Hooking Ampeg Speaker Back Up.

Discussion in 'Amps and Cabs [BG]' started by niki z, Feb 11, 2013.


  1. niki z

    niki z Supporting Member

    Nov 8, 2011
    Nashville, TN
    Can someone please tell me if there is certain way these two pieces need to be hooked up to this speaker (as in a +/-), and if so how do I tell the difference? I plugged in both ways by switching them, and when I turned it on and off the speaker popped, this is also before I got it into the cab.

    If it matters, it's an old Ampeg 15 combo amp I'm trying to put back together after I checked to see what kind of speaker it was.

    Thanks.
     

    Attached Files:

  2. Ribbed wire to the red dot side (usually). BTW the tensile lead on the right in your pic needs to be properly soldered on the terminal board (unless the solder joint is much better on the side we can't see).
     
  3. niki z

    niki z Supporting Member

    Nov 8, 2011
    Nashville, TN
    Are you talking about the solder on the speaker?

    Also, I swear the two look exactly alike, how do I know ribbed one?
     
  4. Yes the terminal strip on the speaker.
    In your pic the wire on the left is not smooth it has some raised edges (ribs) on it, the other wire does not (fully smooth on the insulation).
     
  5. niki z

    niki z Supporting Member

    Nov 8, 2011
    Nashville, TN
    Ok...so 1 wire is 3/4 smooth with one ridge. The other one is almost rectangle shape with 2 ridges and has ----AIW-R--- stamped on it.

    Can anyone else out there help me out, I'm just trying to put this back together to get rid of it.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.