1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

PLEASE NEED YOUR HELP!!!!!DISTORTION!!!!!!!

Discussion in 'Amps and Cabs [BG]' started by Amoilbasso, Jun 2, 2002.


  1. Amoilbasso

    Amoilbasso

    Apr 22, 2000
    Florence
    Hallo everybody,
    HELP!!!!
    I have a problem....
    First of all it seems to me that my eden wt 500(bridged in mono) output limit leds light too much easily:
    gain= 3 o'clock(Input pad IN -12db)
    output=11 o'clock
    enhance= between9 and 10 o'clock
    bass=quite 1 o'clock
    treble=1 o'clock
    Semiparametric equalizer:
    165HZ=at quite 3 o'clock
    1.1hz= at quite 12 o'clock
    around 10kHZ=at 2 o'clock.
    But above all when the amp is set in this way(or similar),my Goliath3 get a terrible distortion when I play double stops on the high notes:for example a g#on D string
    +an A on the Gstring.And then with the amp still set in this way,the cab produce a noisy Pop...StoK..stock...when I slap the E string.
    All this stuff happens with my Fender and my Tobias both.
    PLEASE:ALL THE EDEN USERS TRY SIMILAR SETTING ON THEIR OWN AMP;AND LET ME KNOW YOUR RESULTS!!!!PLEASE!!!!!Other gus opinion are very apreciated too!!THANK YOU VERY MUCH:( :( :(
     
  2. Wxp4759cb

    Wxp4759cb

    Nov 23, 2000
    Columbia, MO
    You might have a blown tweeter.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.