1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Possible causes of noise in my brand new Jbass MIM??

Discussion in 'Basses [BG]' started by FunkyMan, Apr 14, 2010.


  1. FunkyMan

    FunkyMan

    Nov 27, 2007
    Hey gentlemen! I have a brand new Jazz Bass MIM, only 2 months of buying it, and has an annoying noise in the pickups, or maybe the electronics? what may be the solution to solve this problem? a week ago I could check the ground wire that goes to the bridge, and is ok, I put an external cable tied to the bridge (don't know where I read this but it works) and the noise disappeared. Suggestions? thanks
     
  2. endy_y_p

    endy_y_p

    May 2, 2009
    Surabaya
    maybe...just maybe....the ground cable did not correctly touch the bridge...

    just maybe...
     
  3. okcrum

    okcrum in your chest

    Oct 5, 2009
    Verde Valley, AZ
    RIP Dark Horse strings
    Yep. Sounds like the wire to the bridge is pulled loose on one end. Had that on a MIM P I bought, but it was older. It's an easy fix.
     
  4. FunkyMan

    FunkyMan

    Nov 27, 2007
    Thanks! But i've already done this.. i pulled off the bridge to check if the wire was correctly touching the bridge and everything is fine..! so, a second option?
     
  5. okcrum

    okcrum in your chest

    Oct 5, 2009
    Verde Valley, AZ
    RIP Dark Horse strings
    If you wired an external cable from the bridge to ground and the noise went away, the bridge ground wire is NG. Just because the bridge ground wire *looks* OK doesn't mean it's making contact with the bridge. Did you put an ohmmeter on the bridge to ground?
     
  6. Sounds like the ground might have come un-soldered from the control cavity.....
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.