Preamp Gain - crackling sound when I turn up

Discussion in 'Amps and Cabs [BG]' started by Rodan, Jan 2, 2004.

  1. I just turned on my 9-year old SWR Bassic 350 (now known as Bass 350) after a couple of months of no use and discovered that when I turn up the preamp gain knob, I kinda hear this slight but noticeable crackling/buzzing sound coming out of my speaker cabs. I also noticed today that the hiss coming from the speakers was louder than usual (I don't turn off my horns all the way), and although it's been a while since I've used it, I also get the impression that the volume level is a bit lower than it used to be.

    I could certainly use your help in diagnosing the problem. Is this what happens if your preamp tube becomes microphonic, or could it be a more serious problem?

    Any help would be greatly appreciated.

    Also, if I need a new preamp tube, where can I get one and do you recommend any that would complement the SWR circuitry?

    Many thanks
  2. Petebass


    Dec 22, 2002
    QLD Australia
    I can't help you witht the tube, but it certainly sounds like the pot on the gain knob is dirty/dusty. Most repairers should be able to repair that quite easily. It may not hurt to get them to replace the tube while it's open.
  3. Yeah, guess I might just take the head somewhere to get checked out. I was hoping to at least narrow down the sources of the problem.

    Any other ideas on what the problem with my amp might be?
  4. B String

    B String Supporting Member

    Apr 11, 2002
    Los Angeles
    Sounds like the pot is dirty. Go get
    some high quality cleaning/lube spray
    and do it yourself first. It might save
    you alot of time and money. Plus ....
    it couldn't hurt. jmho