Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Preamp headroom on a Mesa M-Pulse 600

Discussion in 'Amps and Cabs [BG]' started by silky smoove, Feb 22, 2005.


  1. silky smoove

    silky smoove Supporting Member

    May 19, 2004
    Seattle, WA
    Since there is no clip indicator for the preamp section of my M-Pulse 600 I've been curious as to the headroom potential of this unit's preamp.

    I've been using it with a Modulus Flea 4 (Nordstrand MM4.2 and Bartolini NTBT), and even when using the passive input it certainly doesn't sound like I'm clipping the preamp, even on high gain settings.

    Since it doesn't sound like its creating a harsh, "squared-off" form of clipping, just pushing the tubes into a nice overdrive, should I be worried? Will my ears be a definite "tell" when this thing starts to clip?

    You'll have to forgive my ignorance, this is my first experience with a real tube preamp. Thanks in advance!
     
  2. kobass

    kobass Supporting Member

    Nov 3, 2003
    Outside Boston
    This is something I've wondered about as well. I have an M-Pulse 600 that I run through an Aguilar GS210 and GS112. My main bass is a Pedulla Thunderbolt with Bart soapbars and preamp (pretty hot output). I have gigged with this at some insane volumes, yet it seems like nothing is even flinching. At least not to my ears.

    Perhaps, Benjamin Strange can give some insight?

    :confused:
     
  3. silky smoove

    silky smoove Supporting Member

    May 19, 2004
    Seattle, WA