Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Preamp tube for eden

Discussion in 'Amps and Cabs [BG]' started by Mikeels, Oct 1, 2002.


  1. Mikeels

    Mikeels

    Apr 20, 2000
    So.CA.
    Been a while since I posted here..........Ussually don't have much to say but I've got a question!
    I blew my Eden wt800's output section up:eek: ,
    two transistors, capacitors and resistors later it's back in service. I think I might have a problem with the preamp tube. I pulled it to replace it as the amp sounds....I dunno...darker than normal. My question is should I use a 12au7 or 12ax7.
    there is nothing on the tube in the unit now except EDEN. (Man, my SVT 4 pro never let me down)
    Thanks for any help
     
  2. Eric Moesle

    Eric Moesle Supporting Member

    Sep 21, 2001
    Columbus OH
    My opinion, replace it with a JAN 5751 tube. I did that in my Eden Navigator, and it made worlds of difference. It adds more tube character as opposed to "fuzz" that the original 12ax7 exhibited.
     
  3. Chuck M

    Chuck M Supporting Member

    May 2, 2000
    San Antonio, Texas
    The original tube in an Eden is a 7025 which is the same as a 12AX7 but with a lower spec for microphonics and noise. A 12AX7 will work fine.

    I've tried my best to like 5751's in my amps but always end up using a 12AX7 or 7025. I have about 20 NIB Sylvania, RCA and GE 5751's. Anybody need one? Email me.

    moses@compuvision.net

    Chuck