1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Problem with schecter

Discussion in 'Pickups & Electronics [BG]' started by braz_b2, Mar 17, 2009.


  1. braz_b2

    braz_b2

    Mar 17, 2009
    I have a schecter stiletto custom 5, which i love. but recently ive been having a problem with it. After I plug it in, i can play for maybe 5-10 seconds before it just shorts out and goes silent. How might I go about fixing it.
     
  2. jarrod cunningham

    jarrod cunningham

    Apr 24, 2007
    sylacauga alabama
    spector basses
    sounds like a preamp problem ... but you have replaced the battery right ??? maybe a barrel jack issue also
     
  3. is it an active bass? maybe you need new batteries
     
  4. stflbn

    stflbn

    May 10, 2007
    Nashville
    Could be the battery... I'd try that first if you haven't replaced it.

    After that it would have to be an onboard electronics issue.


    I don't believe those models have an active/passive switch or pull/push knob, so no easy way to test it. Swap out the battery first.
     
  5. braz_b2

    braz_b2

    Mar 17, 2009
    Thanks. turns out it needed to be soldered better in one spot. and the battery.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.