1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Problems with my SWR Super Redhead

Discussion in 'Amps and Cabs [BG]' started by Frianor, Aug 13, 2007.


  1. Frianor

    Frianor

    Aug 13, 2007
    I recently took possession of an older (Pre-fender) SWR Super Redhead 2x10 combo from my brother, and it has been giving me issues. Any time I play through it, it only sounds distorted, at any volume and any EQ setting. I can turn the tweeter off and it still is this muddy distortion sound. It has received some work in the past, but we have tried all we could think of to fix it, short of replacing major parts. The speakers are new, and sound fine when plugged into another amp. Also, if I play through headphones the tone sounds really clean; there's no distortion. Does anyone know what might be causing this problem and how to get it dealt with? Its a great sounding amp when its in working condition, and I'd hate to have to part with it.
     
  2. Harpo61

    Harpo61

    Dec 15, 2000
    Tampa Bay
    Have you check the tube in pre-amp?
     
  3. Jeff Scott

    Jeff Scott Rickenbacker guru..........

    Apr 11, 2006
    The headphone jack is wired in parallel with the speaker out jack, so I would supect an issue with the speaker jack or related connections, since you say the speakers are new, and the headphones sound fine.
     
  4. Frianor

    Frianor

    Aug 13, 2007
    The tube was recently replaced as well so it isn't that.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.