puzzeling amp problem

Discussion in 'Amps and Cabs [BG]' started by Loel, Oct 2, 2005.

  1. Loel

    Loel Blazin' Acadian Supporting Member

    Oct 31, 2004
    hi curious situation here;i have a gibson gb 440 amp and i have a small 2 space wooden carpeted rack;i had to take the rubber feet off the amp so it would fit in, i put the screws back in,when i did this and fired up the amp it wouldn't work!! i took it out again and put the feet back on and it worked! does anyone know what may have happened.my Q.if i got shorter screws would this cure my problem.thks for your responses. :hyper:
  2. Be very CAREFUL here. I cannot be sure, but it sounds like the feet screws might be extending too far into the amp casing, possibly contacting something. If this is the case, you're probably lucky if nothing got fried. And if this is the case, shorter screws would "probably" work, if these screws are actually needed (without the feet installed) to hold the amp's cover in place.
    Why don't you pull the amp's cover and see what's up in there?

  3. Loel

    Loel Blazin' Acadian Supporting Member

    Oct 31, 2004
    magneto, as luck would have it i contacted dave at thunderfunk a couple of days back to inquire about rack ears for this amp;well he replied last night telling me yes he has the ears,i explained this to him and he said leave the screws "out",so my lesson from this always get expert advice first,thks for the reply. :D
  4. Eric Moesle

    Eric Moesle Supporting Member

    Sep 21, 2001
    Columbus OH
    Back in the middle 80's, I had a GK 800RB, and when I put rack ears on it I reinstalled the feet to make it sit more secure in the bottom of the rack, but one of the rubber foot screws was longer than the others, and I installed that one right under the power switch, which created a short. Boy, did I learn a hard lesson . . . .

    Be VERY careful when removing and reinstalling screws!!!!
  5. Thunderfunk


    Mar 27, 2004
    McHenry, IL
    I was very aware of this in the design of the amp to make sure no screws, however long someone might substitute, wouldn't touch power. I didn't consider under the preamp board, and a couple of guys have shorted out the signal (even tommixx). No harm done. Just remove the screws. I never looked at the original Gibson preamp board, but I guess it has the same problem. It'll be fixed on the next spin of boards. BUT STILL, be aware that you should always use the original screws. Not all sheet metal screws are designed the same, and even if the same size, they might have a different thread cut and end up stripping themselves out. Whenever we find a problem, we make a change to fix it. That's why I say I reserve the right to improve the amp. We've recently added a copper shield to the transformer, the humbucking mod wire which reduces the amp's hum to a level that even my Fluke 87 meter will read with the amp turned off, and have black anodized the heatsink plates for better heat transfer and anodizing is an electrical insulator potentially saving accidental shorts, and have switched to brass screws for the power transistors as they take 1 more degree C of heat out of the transistors. This doesn't mean the amp is cooler, it still generates the same amount of heat, but copper conducts heat faster than aluminum, and especially more than steel. I worked on an MRI design were we used 600 pounds of copper. And we've added a cap to the power switch to de-click it. We'll make more changes as we find ways to make it better.