1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

qsc question

Discussion in 'Amps and Cabs [BG]' started by Hizzoner, Sep 19, 2008.


  1. Hizzoner

    Hizzoner

    Jan 6, 2005
    Chicago area
    I recently acquired a qsc plx 1602(my first rack mount power amp) that was lightly used, and currrently have it running along with a sansamp rbi preamp..

    A couple of questions for those with experience...
    1. what is considered a "normal" amount of noise coming out of a power amp? Is it normal for the qsc to take a moment to power up, then have a slight background bzzzzzzzzz...kinda hard to describe but kinda like a distant sound of an automatic transmission when turning the wheel
    ...after warmup while in operation a faint backgound "presence" is audible...not really white noise but not silence
    ..when playing the notes sound like they should from a sansamp..
    ...an "electronic" scent is in the air upon turning power on...certainly not smoke and barely can smell, but it is there..

    Is this normal?
    Thanks.
    Mark
     
  2. Bob Lee (QSC)

    Bob Lee (QSC) In case you missed it, I work for QSC Audio! Commercial User

    Jul 3, 2001
    Costa Mesa, Calif.
    Technical Communications Developer, QSC Audio
    The PLX amps are extremely quiet, unless one is defective. Does the noise vary as you turn the amp's gain control? Does it go away if you disconnect the input?

    I don't know what you smell, but a power amp itself generally should not produce smells under normal usage. It will produce some heat, which may cause dust accumulations or other stuff to emit some kind of smell.
     
  3. Hizzoner

    Hizzoner

    Jan 6, 2005
    Chicago area
    for the quick reply...
    I have not messed with the knobs much..usually adjust the pre level or the passive pickup knobs on my p and j basses..only using 1 channel at very low setting through a 1x15 cab right now...not noticing any heat or anything else strange about the sound..maybe it has dust in it which needs to be cleaned..

    ...Will try to change levels and see if it changes anything
    thanks again
    Mark
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.