Rattle in my cab !

Discussion in 'Amps and Cabs [BG]' started by Karel Peeters, Aug 5, 2003.

  1. Karel Peeters

    Karel Peeters

    Jun 24, 2002
    Hi there,

    Recently I've bought a second hand SWR Henry the 8x8 cab. It was fine when I tested it in the guys house but when I tried it out in our rehearsal room it started to rattle real bad. As we started to take one of the speakers out, we saw someone had put a plectum between the cone and the magnet part. It was put there with some sticky tape so I think I've been had.
    Does anyone know how to get rid of this noise ?!
    I've spend my last buck on this thing and i'm really p****d about it !!
    Please help me !!!
    (sorry for any mistakes, I'm not English speaking)
  2. Bruce Lindfield

    Bruce Lindfield Unprofessional TalkBass Contributor Gold Supporting Member

    It must have been owned by a 'Fieldy' fan, or heaven forbid, the man himself!! :eek:

  3. The best you could do is buy a replacement 8" speaker for it. If there's a problem between the magnet and cone and that thing was only secured with sticky tape, then all I would know to do is replace the speaker.
  4. You may be able to take it to a repair shop that does recones/alignments but i think it would be more cost effective and better in the long run to just buy a new one.

    Just for the sake of saying, i saw a Peavey 8" on ebay for like $30 just the other day. that would get you through cheap for now.
  5. Karel Peeters

    Karel Peeters

    Jun 24, 2002

    Thanks for your replies !
    Ofcourse I was hoping someone had some sort of trick up his/her sleeve that would help (and that would cost a penny:meh: ) but I thought replacing was the only option too.

    Thnx !