1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Raven Labs MDB-1 buzzing

Discussion in 'Amps and Cabs [BG]' started by timre, Jan 29, 2003.


  1. timre

    timre

    Jul 9, 2001
    Vancouver, BC
    I have a very odd problem that I would like to know if anyone else has had. I use my MDB-1 through to my Alembic F2-B through to a Trace Elliott dual band comp through to a Cable Factory passive DI and out to the board. No amp (I'm on IEM's). I am using the wall wart for the Raven Labs unit and for everything else. I cannot get rid of a buzz when I have the MDB-1 in-line. If I switch the ground lift it doesn't go away. If I ground lift the DI it doesn't go away. If I take it out of signal chain, the buzz goes away. It is like a higher buzz as opposed to a lower hum. I tried using the DI for a while when I first got it and it always buzzed so I stopped using it as a DI. I don't think I really noticed any buzz until I went to the Alembic preamp last year. I used to have a Bass Pod and it didn't have this problem when I only used the MDB-1 as a mixer before the Pod.
    Anyone? help.
     
  2. I've noticed with my PMB-1, that if the batteries are low, it has a tendency to "squeal" - a bit un-nerving the first time it happened, but unmistakable. Now I know what is happening when this occurs, it's not too bad to deal with it - I mostly use the "wall-wart" now, for that very reason.

    What you're describing sounds like a grounding or pick-up problem. Does it occur when you're not using the "wall-wart"?

    Hope this helps -
    -Wil