Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Red LED in QSC

Discussion in 'Amps and Cabs [BG]' started by Davidoc, Jul 27, 2002.


  1. I just had a QSC USA-850 fixed. Yay.

    It works fine now, but whenever its on, if you look into the vents in the front, you can see a red led inside the amp. Red Leds usually mean bad, so I'm not going to use the amp again until I find out what it means.

    Thanks!
     
  2. Phat Ham

    Phat Ham

    Feb 13, 2000
    DC
    The red LED on my Carvin is for showing when the unit is on. Come to think of it, lots of gadgets and gizmos around the house have red lights to show that the unit is on.
     
  3. I got over it and am using it. It's just that last time I saw a red led on it, it cost me $140.
     
  4. Pre EB

    Pre EB

    Mar 15, 2002
    Denton, Tx
    I have the same amp and mine always has the LED on. I haven't had any problems with mine so I wouldn't worry that it's a sign of distress. It's just kind of hard to see so you might have noticed it only after you had the problem with yours.
     
  5. Hmm does it have a fan or cooling mechanism that automatically starts when u plug it into the wall?? I saw a PA amp like this. Before you switch the amp on, if you plug it and its on at the wall, the fans start.

    I rigged mine up like that, i have a LED to show when its on.

    Eh maybe.

    :D:D

    Merls
     
  6. I've seen this before. Amp designers sometimes put indicators on the inside of the amp, for repairman use only. They don't want to scare off the end user with too many check lights. My homebuilt amp has 6 leds on the inside. 4 of them indicate the main power supply voltages (there are 8 supply voltages) and 2 of them indicate protection mode.

    Maybe QSC's Bob Lee (TB member) can inform you about the function of the one in your amp.
     
  7. Bob Lee (QSC)

    Bob Lee (QSC) In case you missed it, I work for QSC Audio! Gold Supporting Member Commercial User

    Jul 3, 2001
    Costa Mesa, Calif.
    Technical Communications Developer, QSC Audio
    The red LED inside the USA 850 doesn't mean anything; it's just a way of getting about a 1.5 volt drop with one inexpensive component. If it's on, you can be sure that part of the circuit is working!
    :D