1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Replacement for a blown Mesa Powehouse 10"

Discussion in 'Amps and Cabs [BG]' started by Chazinroch, Apr 16, 2006.


  1. Chazinroch

    Chazinroch

    Feb 2, 2003
    Ontario N.Y.
    I have an older Mesa Powehouse 2X10 (8 ohm, 600 watt) cabinet. One speaker has a bad buzz/rattle which I assume that it is toast. Any recommendations for a relacement? What brand does Mesa use? I'm guessing that the speakers are 16 ohm in parallel (I think that gets it to an 8 ohm load). There is no info on the speaker itself. I tried to take the 10" from my Mesa Venture but the cutout in the Powerhouse is 9.25" and the Venture 10" requires a 9.5" cutout. I don't want to hack up the cabinet. Any advice is much appreciated.
    :confused:
     
  2. billfitzmaurice

    billfitzmaurice Commercial User

    Sep 15, 2004
    New Hampshire
    Owner, Bill Fitzmaurice Loudspeaker Design
    Contact Mesa.
     
  3. snowdan

    snowdan

    Feb 27, 2006
    that should be a standard EV 10".
     
  4. MotorTed

    MotorTed

    Apr 16, 2006
    CT, USA
    I've heard Mesa did use Eden 10's as well. I also have a 210 cab but I dont know how to tell the difference in speakers. Now that you have peaked my curosity, I'll pull the panel off of the back and get back to you.
     
  5. Chazinroch

    Chazinroch

    Feb 2, 2003
    Ontario N.Y.
    Thanks for the feedback so far. I have an e-mail in to Mesa, so I hope to hear back from them on Monday. I'll post their reply.
     
  6. Chazinroch

    Chazinroch

    Feb 2, 2003
    Ontario N.Y.
    Finally got in contact with Mesa. The 10s that they use in the Powerhouse cabs are some brand that I have never heard of from Loudspeakers Inc. They are 16 ohms and rated at 300 watts. I ordered a replacement - they ain't cheap!!!
     
  7. MotorTed

    MotorTed

    Apr 16, 2006
    CT, USA
    I checked my 2-10 cab and found the same no sticker or marking that you have. My cab is older and is only rated for 300 watts total. Good stuff none the less.
     

Share This Page