1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Rf noise from a Lakland 55-01. should i change PUP's?

Discussion in 'Pickups & Electronics [BG]' started by dave_bass5, Dec 26, 2006.


  1. dave_bass5

    dave_bass5

    May 28, 2004
    London, UK.
    Guys
    I got a new 55-01 back in the summer and loved it. i then made the mistake of messing with it and i got a second hand NTMB installed. since then i get RF noise when ever i sit in front of my PC with it. Its something i thought i could live with and have done lots of gigs with it without any problem (i am planning on getting a LCD for my PC) but at my last gig it was really loud. this was the first time i was using a new cab but im sure it was coming from the lighting rig, although there were no lights on stage.
    So, my question is if i changed the pup's to something else is there a good chance the RF will go. of course i realise i would have to get the right ones but i want to know if its just the shielding in the bass thats the problem and if im stuck with it.
    also, if new pup's would help any suggestions on which ones. I believe Nordstrand Dual Coils are a direct replacement.
    Thanks for any help
     
  2. Espidog

    Espidog

    May 19, 2006
    UK
    Hi Dave,

    Blimey, what with this and the MAG going belly-up, you're not having much luck, are you!

    Of itself, a healthy NTMB shouldn't be picking up RFI at all. Given that the unit was 2nd hand, and that the noise only began after it was installed, you're pretty much left with these possibilities:

    1) Faulty NTMB to begin with.

    2) Healthy NTMB, but incorrectly installed. This could be insufficient/wrong screening of the NTMB itself or of the Lakland's pickups, or maybe an earth loop caused by too many paths to earth being created.

    To determine exactly what's wrong, you really need to examine the innards thoroughly or get it diagnosed by someone qualified. I certainly wouldn't be thinking about changing your pickups. They didn't pick up RFI before you had the NTMB fitted, and I bet you they're not to blame now.
     
  3. dave_bass5

    dave_bass5

    May 28, 2004
    London, UK.
    Thanks for the reply.
    Ive still not got the MAG back so i dont konw what state its in but i dont miss it at the moment so its no big deal.
    As fro the 55-01. i think ill get the original pre put back in and see what happens. im no good at this sort of thing so ill get a pro to do it.
    I have the NTMB installed by the Gallery so im sure its been put in right. i did mention it in the shop and they gave me some waffle about it being an active pre etc but as you said, it souldnt do it. Saying that i have read over on the Dudepit forum that a few people have this problem with 55-01 using the stock pup's as well which confuses the situation.
    Also i dont get the RF noise which the bass in passive mode so confused even more.
    I would like more bite from the bass so changing the pup's would be on the cards in the future anyway.
    Hope you had a good christmas as well.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.