S.O.S on fishman BP-100 clip!

Discussion in 'Amps, Mics & Pickups [DB]' started by Sheraton, Sep 12, 2002.

  1. Sheraton


    Sep 12, 2002
    KL, Malaysia
    hi, I'm Vincent, a gigging bassist in Malaysia (somewhere near Singapore).

    I need some urgent assistance.

    I desperately need 1 pair of felt-covered spring clip, for my Acoustic Bass Pickup, BP-100; because it's original clip is stolen by another musician (everyone take note, beware of thieves... )

    The original set is purchased by my friend 7-months ago, from Ken Stanton Music, Marietta GA. But she had moved back to Malaysia, so nobody could help me on this. I've called a few music shops in Singapore, but they DON"T even have the whole set, let alone the parts...

    So whoever knew where can I order the clip online or any other ways please help me out on this.
  2. erik II

    erik II

    Jul 11, 2000
    Oslo, Norway
    You may also glue the discs to the bridge with thin two-sided adhesive tape. Some say this improves the sound of the Fishman too...
  3. Seppie


    Aug 14, 2002
    Austria, Vienna
    as i read al these threads about the fishman...
    ...i think that everything than the original clip montage should be better...:D

    gruesze sebastian
  4. mje


    Aug 1, 2002
    Southeast Michigan
    Fishman recommends using a drops of hot melt glue to secure the chips.
  5. jimclark68


    Dec 16, 2000
    Morganton, NC
    Before I wised up and tossed my Fishman, I used the double-sided tape trick, too. I never tried the glue as Fishman recommended, but the tape allows you to remove the pickups much easier if you're experimenting with different locations. I used to have them further away from the edge of the bridge and mounted on the tailpiece side of the bridge. I felt like it helped with the tone a bit; it probably didn't, but I'm never one to shy away from a good placebo effect.
  6. Don't be upset about the clips....You could have had mine but I have already thrown mine away. After 24 hours of having the Fishman installed I note that they moved all over the bridge and were only going to cause trouble so,I went straight to the tin of Contact Glue. A small layer on each surface and let it dry ...then place sensor onto Bridge and that's it! Sounds a LOT better when adhered to the bridge than using the clips.

  7. lermgalieu

    lermgalieu Supporting Member

    Apr 27, 2000
    Palo Alto, CA
    Dang, I didn't know about this trick when I had my Fishman, or maybe I woulda kept it! I will call the friend I "sold" ($30) it to and relay the tip!
  8. I had the same problem...missing clips, but I got replacements fromm www.lemurmusic.com. The delivery was fast, and they were really cheap ($5for the set I think). However, that said, I just had a look at the lemur site, and couldn't find the page in the 'on-line store section', but try this:

    - Go to this site: www2.mailordercentral.com/lemurmusic/Home.asp

    - In the Product search type in A1460 (the code for the clips last time I ordered)(might be case sensative)

    -Buy them

    -Wait for delivery

    -Get them in the post

    -Stick em on