SansAmp Bass Driver DI is buzzing.....

Discussion in 'Amps and Cabs [BG]' started by DirtDog, Sep 15, 2003.

  1. DirtDog


    Jun 7, 2002
    The Deep North
    Plugged the unit in after a few weeks of non use - sitting on a desktop the whole time. This unit is about a year and half old and has been used regularly on gigs and rehearsals - it's seen some "road time"....

    Plugged bass into DI and DI into amp, kicked on the DI and got a nasty non-SABDDI approved buzzing sound.

    Plugged straight into amp - no problem, no noise.

    Changed cables - patch back through DI - noise is back.

    Changed battery - noise remains.

    I'm sure this will be a warranty situation, but wanted to check here first if anyone else has experienced this problem and what your solution was before making the trip to the LMS (local music shop).


    Edit: Oh, and it's not the settings - the noise remains no matter what the controls are set at. Like I said, it's a "non-SABDDI approved noise" not the sweet "SABDDI-approved" distortion and it's not a grounding problem - I run it with a battery and the problem has recurred in different buildings.
  2. chardin


    Sep 18, 2000
    Just guessing but you might have a build up of crud in one or more of the 1/4 inch jacks.
  3. Chris A

    Chris A Chemo sucks!

    Feb 25, 2000
    Manchester NH
    Is it sitting on top of the amp?
    Sometimes if it's too close to the amp it'll buzz.

    Chris A.:rolleyes: :bassist:
  4. bassalicious


    Sep 16, 2003
    Mine has started doing the same thing except it is an intermitent very loud buzzing squeal and the signal will sometimes even cut out. Remove the problem. New batteries, cables have not solved it.