1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Serious problem with my pedals

Discussion in 'Effects [BG]' started by Agito, Sep 28, 2009.


  1. Agito

    Agito

    Jun 27, 2009
    Hi TB
    I got a weird and annoying problem with my pedals

    After a while (Or even it starts like this when i turn on everything)
    The effects (Mainly the ODB-3 and the Big Muff) Go into a state which i can feel the lows but all the highs are cut, As we all know know the fuzz really gives the high EQ sound (I heard it ok and then went down to this weird mode)

    I tested two pedals separately- ODB--3 and the Big Muff
    Happens in both

    I tried a battery instead of the power supply, Still happens.
    Different basses (Active and passive) Still happens.
    Different cables

    But didn't try a different amp, But it's weird cause my amp only been replaced recently, It might be the problem.

    It sounds like you take the high button of the eq and lower it to the minimum db
    So you can hear only the lows and a volume drop.

    Please help me TB, I don't know what to do...
     
  2. Bofee

    Bofee

    Aug 19, 2005
    Grass Valley, CA
    Have you tried the amp without any pedals ?
     
  3. Agito

    Agito

    Jun 27, 2009
    Totally normal on clean signal, Maybe a volume drop, Im not sure at all.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.