1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Sire P7 active preamp dead

Discussion in 'Pickups & Electronics [BG]' started by AlexWinchester, Oct 14, 2018.


  1. AlexWinchester

    AlexWinchester

    Oct 14, 2018
    Hi! Newbie here on the forum

    Just got my Sire P7 and I reallllyyyy Like it so far but today the active preamp died! I’ve only had it for about 1 week so im wondering if there is a potentiall problem here or if its just the batteries?
    Going the check with new batteries tomorrow if that does it
     
  2. Funkinthetrunk

    Funkinthetrunk Registered User Supporting Member

    Contact Sire, they are very helpful.
     
  3. mustBmtd

    mustBmtd Supporting Member

    Sep 28, 2012
    Tennessee
    Check your pickups first. After that see if you have sound output by switching to passive mode.
     
  4. mustBmtd

    mustBmtd Supporting Member

    Sep 28, 2012
    Tennessee
    Forgot to mention, check your batteries.
     
  5. AlexWinchester

    AlexWinchester

    Oct 14, 2018
    It was probably the batteries! Problem appears fixed when I swapped the batteries so all is well!
     
  6. Funkinthetrunk

    Funkinthetrunk Registered User Supporting Member

    Don't forget to unplug the cable from your bass when not in use.
     
    JohnPaulSmith likes this.
  7. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    Nov 26, 2020

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.