1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Solved: What's wrong with my DB112?

Discussion in 'Amps and Cabs [BG]' started by DriesG, Oct 3, 2013.


  1. DriesG

    DriesG

    Feb 27, 2009
    Gent (Belgium)
    Hey guys, last weekend I played a gig with my Aguilar TH500 and a DB112 cabinet. Worked perfectly. Today on rehearsal, plugged in my bass and ... no sound. Changed cables, power cords, speaker cables, tried another amp (which worked fine with my bass). There's only some high frequency noise coming out of the tweeter, nothing from the 12" speaker. At home, I tried another DB112 which worked fine (same cables, bass...). I opened up the cab to check for loose connections and everything looks normal. I took of the grill cloth to check the conus, and it looks totally normal. When moving it, it feels normal. I used the same setup last saturday without any problems and today it doesn't work anymore... :crying: I've been using this setup for years with a DB751 on many gigs, some of them really loud with a second DB112. This last gig was a low volume jazz concert, so I can't believe I've fried it... Any ideas?

    Edit: Opened it up to do some measurements. After reinstalling all the cables, it worked fine. Probably a ground issue with a bad/loose connection. BTW Marco at Aguilar contacted me and suggested to check all the internal connections, like dmusic148 said. He wrote that it's rare for that to happen but check this first if you experience a similar problem.

    Thanks for the answers guys.
     
  2. rollopizza

    rollopizza

    May 17, 2006
    UCLA, OHIO
    Try another head with it to make sure it isn't the head and it's the cab., check the cable first.


    rp
     
  3. It's probably a loose connection on the crossover. Pull it out and have a look at the wires/wire connectors leading to the woofer.
     
  4. lburton2

    lburton2 Les Is More

    May 15, 2008
    Detroit, MI
  5. rollopizza

    rollopizza

    May 17, 2006
    UCLA, OHIO
    what was it?

    rp
     
  6. lburton2

    lburton2 Les Is More

    May 15, 2008
    Detroit, MI
    He added an edit to the post
     
  7. rollopizza

    rollopizza

    May 17, 2006
    UCLA, OHIO
    I missed it thank you.

    rp
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.