Spector NS2A Electronics Help Needed - EMG / HAZ

Discussion in 'Basses [BG]' started by Jim C, Dec 3, 2016.

  1. Jim C

    Jim C I believe in the trilogy; Fender, Stingray, + G&L Supporting Member

    Nov 29, 2008
    Bethesda, MD
    My NS2A came with active EMG's and a Koren HAZ clone pre-amp.
    This bass is volume, pan, treble, and bass
    Some say these were called artists models.

    The P pup on mine stopped working properly while sitting in the guitar stand.
    The bass side of the P has much lower output than normal.
    The treble side of the P pickup has no output.

    These wires connect to plastic standoffs on the circuit board that have an allen screw top.
    The design looks like the plastic cylinder uses the screw to hold the wire down.
    If I turn these screws, the entire plastic part turns and does not release the wire from the holder.

    The circuit board looks to be stapled to the base so it would be much easier to trouble shoot from the cover side.

    Any thoughts as to the problem and/or how to remove wires for trouble shooting?
    TIA
     
  2. NigelD

    NigelD Supporting Member

    Aug 14, 2013
    Ask in the Spector Club,someone can help.
     
  3. Jim C

    Jim C I believe in the trilogy; Fender, Stingray, + G&L Supporting Member

    Nov 29, 2008
    Bethesda, MD
    I tried that first but thanks for the suggestion.
     
  4. sheltjo6

    sheltjo6 Supporting Member

    Jun 10, 2012
    California
    Can you post a photo of the preamp and where the pickups connect to the pre?
     
  5. McCarrigan

    McCarrigan

    Aug 29, 2015
    Hello with a passive emg there is no problem when installing them in the pre HAZ??

    I'm thinking of replacing the passive spector, by passive emg.