Spector overloading Preamp

Discussion in 'Basses [BG]' started by jhan, Feb 19, 2010.

  1. jhan

    jhan Guest

    My Spector Euro 5 is overloading my preamp. I get a distorted sound from my speakers when I lay into the strings hard. Have the gain on my SVP Pro dialed fairly low, no peak light, and it's still happening. I also have the both volume knobs on the bass dialed very low, and the bass and treble knobs backed way off.

    No problems at all with my passive Warwick Corvette Standard.

    Any help would be appreciated. Tks.
     
  2. Rickett Customs

    Rickett Customs

    Jul 30, 2007
    Southern Maryland
    Luthier: Rickett Customs...........www.rickettcustomguitars.com
    How close are the pickups to the strings? Try lowering them a bit. I have a Euro5, i've found with the EMG's in general, if they're to close to the strings this will happen.

    Also, make sure you have a good battery.
     
  3. does your amp have a active/passive switch?? that could be the problem
     
  4. bickele

    bickele

    Dec 29, 2003
    Bergen, Norway
    have you checked the battery?

    b.
     
  5. jhan

    jhan Guest

    I'll check the battery. (Duh!)

    Good on pickup height. I lowered the pickups right when I got the bass. Those things were high, man.
     
  6. cetera

    cetera

    Apr 29, 2004
    Surrey, England
    Endorsing Artist: Spector Basses & Cort Basses
    Have the volumes full up and the bass/treble completely down (this is flat on the tonepump pre-amp).
    Check the battery
    Engage any db pad witch on your amp and keep the amp gain down to start with.

    All should be fine.... & build from there....