1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

SpectraComp loses Toneprint after power down: Diagnostic

Discussion in 'Effects [BG]' started by LeSonyr, Nov 16, 2018.


  1. LeSonyr

    LeSonyr Supporting Member

    Dec 27, 2012
    I have seen this issue in buried in other threads or in old threads so I thought I start a fresh one just related to this issue.

    My SpectraComp Bass loses the toneprint when I power down. I tried updating the firmware. That did not work. Here's what I found out:

    If I power it down by unplugging the 9V DC input into the pedal itself, it does *not* lose the Toneprint. However, if I power down by turning off the power strip that my 1spot or my T-Rex power supply is plugged into, it does lose the Toneprint. So a sudden loss of power keeps the Toneprint but a more graceful decay loses it?

    I saw an old thread about gradual memory loss but it was very old. I was wondering whether anyone had any new insights/fixes, besides "get another pedal".

    I've contacted TCE. I'll post what they say, if anyone is interested.
     
    Kevnn4 likes this.
  2. Johnny Mac

    Johnny Mac Riff-finder General Supporting Member

    Sep 28, 2005
    Springfield, MA
    There was a firmware update that fixed this but was not available on TC's website for reasons that are unknown. If the firmware you installed was the one currently available, it might not be the one that fixed the issue.

    TC's customer service provided the updated firmware, but I've heard that some of their service reps aren't even aware of it. Someone here may still have it on a Dropbox or Google Drive.
     
  3. PhatBasstard

    PhatBasstard Spector Dissector Supporting Member

    Feb 3, 2002
    Las Vegas, NV.
    Also, don't forget to "prime" the pedal before any update.
    You have to hold down the button while plugging in the power.
    Release the button when the light blinks.
    THEN update.

    This will be obvious to some but TC is not good at pointing this out.
     
  4. dave_bass5

    dave_bass5

    May 28, 2004
    London, UK.
    I have the ‘fixed’ firmware version. PM me if you need it. This was sent to me by TC themselves so it’s not a hack or anything. Not sure if the version on thier website is more upto date though, been a while since i looked.
     
  5. LeSonyr

    LeSonyr Supporting Member

    Dec 27, 2012
    I don't have the "fixed" firmware update and TCE has not answered any of my emails. Boo.

    dave_bass5 kindly offered to send it to me. But if anyone else has it and can share it, you would also be kind. Thanks dave_bass5
     
  6. dave_bass5

    dave_bass5

    May 28, 2004
    London, UK.
    Yep, just emailed the email i was sent with the links in it.
    I’m not connected with TCE or any other company, so use at your own risk. It worked for me though.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.