Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

still suffering from clipping issues

Discussion in 'Amps and Cabs [BG]' started by violatedppl, Sep 17, 2005.


  1. as some of you may know I have a peavey tmax and tvx 412. I really like the tone of my set up, but today at band practice The amp started to have the clip light come on, although I noticed no clipping of the amp. could this cause damage to my amp or speakers ( the cab is rated for 1200 watts if it makes difference) this clipping happend only with my master on 3.5 and with my tube pre about 4-5. I had this problem before with a 5r but this was with my pbass so. Im not sure if I should take it to a tech and have it checked out or what. and thanks for all the help.
     
  2. billfitzmaurice

    billfitzmaurice Commercial User

    Sep 15, 2004
    New Hampshire
    Owner, Bill Fitzmaurice Loudspeaker Design
    If the clip indicator is on the input level turn up the master, turn down the gain.
     
  3. Be sure it was the clip indicator too. I don't want to sound condescending or anything, but there is the clip indicator and the compressor(limiter?) indicator, and they both turn red. At first since I had never seen anything turn red on my amp I freaked because it was happening often,but I realized it was just the limiter.
     
  4. I am sure it was the light for the power section. when I use the tube pre, is doesnt clip. ONly the SS PRE will clip which sound god awful. but Im pretty sure this amp doesnt have a limiter but Ill look through the manual again.

    I just looked at it and the light is the DDT power amp compressor comin on. now I feel a little better.