1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Strange amp noise... Battery?

Discussion in 'Basses [BG]' started by ThePrometherion, Mar 19, 2009.


  1. ThePrometherion

    ThePrometherion

    Mar 19, 2009
    Hi, everyone, I'm a new guy here, and sorry if this has been posted before, i really tried looking for something like that...
    My problem is that I have an active Ibanez GSR205 and Ibanez SW65 amp (I am a beginner) and today, somehow when I turned everything on, i got this terrible thumping noise, like someone would bash a mic to his hand (or something like that, I am not that good at english). I turned it of, and when iI turned everything on again, i got this strange noise and a bit of distortion. I had this distortion once but it somehow disappear. So, can it be that my battery is messed up? I would be very thankful for any help I can get and sorry if my description is muddled, I am not an English speaker :meh:
     
  2. ErebusBass

    ErebusBass

    Feb 20, 2008
    Madison, WI
    Why don't you change the battery, and then ask for help? It very well may fix your problem.

    "Thumping" sounds like it might be a jack thing to me.
     
  3. RexNFX79

    RexNFX79

    Jan 12, 2009
    TENNESSEE
    That would be my guess too.
     
  4. olistorck

    olistorck

    Sep 16, 2007
    oviedo,spain
    +1:rollno::rollno:
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.