1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

SVT-450H hiss sound!!

Discussion in 'Amps and Cabs [BG]' started by Mimazo, Sep 9, 2008.


  1. Mimazo

    Mimazo

    Jun 23, 2007
    Santiago - CHILE
    Hi Everyone!, greetings from Chile ;)

    I've purchased a SVT-450H solid state amplifier about 4 months back from now. From the very begining, this amplifier right after aprox 5 minutes of having it on produces a very loud and intermittent hiss, like a disconnected cable somewhere inside of it. Actually by turning the Master volume to 0, it stops. Apparently it isn't related with the Gain control because when I turn the gain up or down, the hiss sound don't vary.

    This hiss sound dissapears after a while of having the amplifier on (let's say about an hour) no matter if you were playing or not, it looks like after a 'warming up' period of 1 hour it gets stable somehow.

    Is this a normal behaviour?, is there a reported incident about a similar issue with this equipment??, ANY CLUE???...thanks a lot my felow bass players!!
     
  2. fenderhutz

    fenderhutz Supporting Member

    Jan 28, 2007
    Harpers Ferry WV
    If that thing has preamp tube I would change it.
     
  3. Mimazo

    Mimazo

    Jun 23, 2007
    Santiago - CHILE
    mmm, actually I'll get a SVP-PRO very soon....if I bypass the preamp of this head by using the SVP-PRO, could I get this solved?....

    Rick
     
  4. RickenBoogie

    RickenBoogie

    Jul 22, 2007
    Dallas, TX
    I don't know if adding a preamp in front will solve your problem, but it will improve your tone, for sure. Not sure what the hissing's all about, maybe you could take it to a repair shop?
     
  5. I had an SVT 350 that had the same problem. Does it his when the treble knob is anywhere but zero?
     
  6. Mimazo

    Mimazo

    Jun 23, 2007
    Santiago - CHILE
    Yes bigblondeafro87 !!!!, what I've observed is when the treble knob is close to 0 , the hiss reduces but not 100%.....how did you get it solved in your case?, thanks man...

    Rick

    PS: thanks RickenBoogie as well : )
     
  7. mrkreuzschlitz

    mrkreuzschlitz

    Jun 30, 2008
    Dacula, GA
    uh, dude,

    your head SUCKS! haha just kidding.
    it might be a flaw in the head.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.