1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

SVT 4PRO not powering up

Discussion in 'Amps and Cabs [BG]' started by wooj, Aug 6, 2012.


  1. wooj

    wooj

    Jan 25, 2011
    Detroit Rock City
    hello all,
    in the middle of rehearsal the other night my svt 4pro went out :crying:
    i switched it off and on again
    the lights flashed but nothing
    this may have been covered already ( i'm sure )
    and if it has, please point me in the right direction
    but i figured that there are many of you out there who know more about these things than i do and maybe it's something obvious. i'd just like to know what i'm looking at as far as repairs go before i bring it in. thanks everyone !!!
     
  2. DanRJBrasil

    DanRJBrasil

    Jun 10, 2007
    tech time
     
  3. hodgy

    hodgy

    May 5, 2004
    Bothell, WA
    Customer Support- Ampeg/ Line 6
    +1
    Is in new? Did it smoke? Did you look at the fuse? What kind of cab set up are you using?
     
  4. RickenBoogie

    RickenBoogie

    Jul 22, 2007
    Dallas, TX
    Yup, only a qualified amp tech can tell you the problem, and fix it. But if it's under warranty, use that instead. Good luck.
     
  5. wooj

    wooj

    Jan 25, 2011
    Detroit Rock City
    thanks much you guys !
    i'll bring it in :(
    no smoke, no fuse issue
    i'm using it with an old MIA 4x10
     
  6. wooj

    wooj

    Jan 25, 2011
    Detroit Rock City
    i have an update for anyone interested haha
    it's powering up, although the power light isn't on
    the mute switch light works, the eq engage light works, the amp is humming but no output and no power light
    thanks again !
     
  7. Stop using it before the humming becomes a loud pop and smoke comes from the amp and/or speaker cab!!!
     
  8. wooj

    wooj

    Jan 25, 2011
    Detroit Rock City
    hahahahaha sounds good to me !
    thanks
     
  9. hodgy

    hodgy

    May 5, 2004
    Bothell, WA
    Customer Support- Ampeg/ Line 6
    Sounds like it's still tech time.
     
  10. Yes before it becomes a lot more expensive! ;)
     

Share This Page