1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

SVT II Pro mute issue

Discussion in 'Amps and Cabs [BG]' started by tchristian, Mar 23, 2017.


Tags:
  1. tchristian

    tchristian Supporting Member

    Nov 18, 2011
    Missoula, MT
    My son's SVT II pro won't come out of mute. The green power light comes on normally. He keeps the mute buttoned pushed while powering up. When he comes out of standby and releases the mute button the mute light stays lit and there's no output. It happened a few times over the last year and a half. When it did he used a different amp and the next time he tried the II pro it would work fine.

    This last time the amp started and ran normally for a few minutes, then the mute light (red) flickered to on while the output faded away in a few seconds. He switched to standby and let it cool for 5 minutes, then brought it back out of standby. He got a few muted notes before the amp faded back out while the light flickered/faded back on.

    He re-tubed it a few months ago. The problem is older than that. We have neglected most of the simple fixes. We will do those next: clean the preamp out/power amp in jacks and/or jumper them, same for tuner and footswitch jacks, clean tube pins and sockets (Deoxit), clean the dust out of it.

    In the meantime and because I'm over eager I guess, we have it partially torn down on the bench for inspection. We found 3 interesting things. We're hoping you can give us your thoughts on these 3 things before we put the boards back in and do some more basic testing.

    First, D34 (1N914) on the power amp board is burned off. The area is circled with old felt pen markings that go under the hot melt surrounding R61, which measures just under 32 ohms. Someone went out of their way to mark it.
    IMG_2759.JPG

    Second, there is a capacitor soldered across R47 and R49 (same board) - a mod of some kind.
    IMG_2757.JPG

    Third, C17, C18, and C21 are slightly bulged on top. The others feel flat.

    Many thanks for your ideas and insights. theo
     
  2. tchristian

    tchristian Supporting Member

    Nov 18, 2011
    Missoula, MT
    Looking again at the drawing/parts list maybe my R47/R49 cap question is actually C38 and is correct?
     
    Last edited: Mar 23, 2017
  3. tchristian

    tchristian Supporting Member

    Nov 18, 2011
    Missoula, MT
    Been reading for a few hours - glad to be able to find technical discussions of the SVT and am picking up a newfound appreciation for the folks who know what they're doing inside these amps. I'm going to blunder along and do what I can with it unplugged. If it comes to bench testing live I'm not equipped for it and will have to hire someone, if I can find someone local, which is not likely.
     
  4. tchristian

    tchristian Supporting Member

    Nov 18, 2011
    Missoula, MT
    It was busted, now it ain't
     

Share This Page