Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

SVT trip #4 is back!

Discussion in 'Amps and Cabs [BG]' started by Rockbobmel, May 21, 2002.


  1. Rockbobmel

    Rockbobmel Supporting Member

    Just got my amp back for the 4th time.A new standby switch, preamp converted for 12AX7s, clean, bias, & adjust. I'm goin' to beat the $#!+ out of it this Friday night. I hope this is the last bug. A new tech from Boston. I had to drive two hours each way TWICE, plus a fair amount of pesos, but if it fixes the problem, then OK.

    I know Vic D. will want to know, so I'll report back on Saturday.
     
  2. Woohoo!

    I hope it works real good. You've waited and fooled around and spent a bunch of money. You deserve years of trouble free tone... Let us know how friday goes!
     
  3. VicDamone

    VicDamone

    Jun 25, 2000
    Damn! It's to bad you can't get Psycho to give it the onceover. Hang in there Bob.
     
  4. Rockbobmel

    Rockbobmel Supporting Member

    I brought my Eden amp setup for backup, but the SVT roared in all it's glory all night. The cabs I ended up using were the D-410 XLT and D-118 XL, stacked sideways with the 410 on top. I was worried that the 18 would be mushy, but the 410 kept it tight. This amp has authority!!
    I ruled the band sound. I did however use my SansAmp BDDI in front of the amp with all control at 12:00 except blend/full on. I did this to calm the SVT's bite and it also added more growl. The amp was set mostly flat with the bright switch on, and bass at 2:00. The volume in normal was set at 9:00 and I had to back my bass off a bit and pluck with a softer touch.

    The amp brought out the character of the FBass, Warwick and the 12 string.

    Me Sooo Happy!!! Thanks for listening.