1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

svt4pro at monbridge

Discussion in 'Amps and Cabs [BG]' started by torkelboy, Feb 24, 2008.


  1. torkelboy

    torkelboy

    Feb 24, 2008
    HEY!!

    I play an SVT4pro through an ampeg 610hlf
    I've read about that special speakoncable you need to play in mono and to all 1200w, i'm fairly certain that my speakoncable is not one of them.


    My question to you guys is as follows:
    If you have depressed the mono/stereo-switch, and your speakon cable sits in the Monogridge-output on the head, but the cable is not wired as ampeg intended. what happends?

    greetz from sweden
    /Erik
     
  2. Jerrold Tiers

    Jerrold Tiers

    Nov 14, 2003
    St Louis
    it acts the same as if you plugged into the channel 1 speakon. Only channel 1 is driving the speaker, and the power is just the channel one power at that impedance.

    You must move the wire from the "1-" connection to the "2+" connection on the cable's Speakon connector in order to get the actual,bridged mono connection.

    it isn't usually very hard to do that. The connections are via small screws that hold the wire, and only need to be loosened to remove and reconnect the wire.
     
  3. torkelboy

    torkelboy

    Feb 24, 2008
    thank you!!!!!!!! I will fix this today, i was a little confused when i did'nt notice any differnce between stereo and mono!
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.